FICSIT Augmentation Database

Logo LogoText

Getting Started with SatisfactorySaveEditor

This guide will walk you through how to download SatisfactorySaveEditor and open your save file.

Table of Contents

Scroll to heading not yet implemented in ficsit.app. These links won't do anything.

Installation Instructions

Parts of the Editor

Additional Info

Installation Instructions

Click to Expand
  1. Not This Button

    • Don't download by clicking this button. This button downloads the source code, which you will have to compile yourself if you'd like to use.

    BadButton

  2. Go to the releases page and download the latest version by clicking Assets and then choosing the topmost file, which will say something like SatisfactorySaveEditor-vX.X.X.zip. AssetsDropdown OpenAssetsDropdown

  3. Save the file somewhere on your computer that you will remember.

  4. Extract the zip file and run the SatisfactorySaveEditor.exe file contained within

    exe

  5. If a dialog box comes up, click More Info, then Run Anyway. SmartScreen1 SmartScreen2

  6. Open your save file by pressing File > Open ... You should already be in the directory where your save files are stored. If not, navigate to C:\Users\YOURCOMPUTERUSERNAMEHERE\AppData\Local\FactoryGame\Saved\SaveGames or wherever you have your AppData folder set to be located.

    FileOpen

  7. You're set! Continue reading for more info, check for additional guides in the Guides section, explore on your own, or ask for help in the #savegame-edits channel on the discord for help with specific tasks.

Parts of the Editor

Click to Expand

EditorPartsPicture

  • Red - File Menu
    • Allows you to save your changes, open another save file, jump to a particular tag, and change your preferences for the editor.
  • Orange - Cheats Menu
    • Perform various changes to your save such as unlocking all researches, dismantling large quantities of buildings, enabling no cost building, etc.
  • Yellow - Help Menu
    • Contains useful links for getting help with the editor and reporting issues.
  • Green - Search Bar
    • Searches the Entity Name field of all save objects for a term, ex. "Player"
  • Light Blue - Tree View
    • Contains all entities present in the save, organized the way Coffee Stain has chosen to organize their save files. Hover over items to get a description of what purpose they serve.
  • Blue - Common Properties
    • Properties common to all entities (but not always used) such as position, name, etc. Not all of these fields can be changed.
  • Magenta - Unique Properties
    • Properties unique to the object you have selected. You can add properties by clicking the Add property button or change properties by changing the values in the boxes. Be sure to save your changes!

Additional Guides

Click to Expand

Additional Tips (WIP)

Click to Expand
  • Modifying entities
    • To modify an entity, select it in the Tree View (light blue) and its properties will appear in the Common Properties (blue) and Unique Properties (magenta) panes. To change the value of a property, simply change the text in the box. TagModify
  • Hovering for More Info
    • Hover over entities to view their description, and click the triangle next to them to open them. HoverDemo
  • Jumping to an entitiy
    • You can use File > Jump to tag... to scroll directly to an entity if you know its Entity Name. To obtain an entity's name, right click on it from the Tree View (light blue) and choose Copy name. You can also copy it from the Entity name: field in the Common Properties (blue) pane.

Info

Created: Jun 18, 2019, 11:11:28 PM
Views: 6,534

Author

budak7273